Limit of CSV Data Source Shadow Assets?

(Lewis) #1

Any idea if there’s a limit somewhere in the system as to the number of shadow assets that show up when you create a CSV Data Source?

I’m uploading over 50 records from a CSV file but I only see the first 50 as shadow assets under the CSV Data Source.

This is for a critical part of our website and I want to be sure that it isn’t suddenly going to ‘forget’ everything from record #50 onwards!

Any ideas?

I’m on version btw

(Aleks Bochniak) #2

I remember there used to be a hard limit of 10,000 back in the day - but don’t know if that still applies to matrix 5+

(Nic Hubbard) #3

You mean in the asset map you are only seeing 50? Have you tried an asset listing?


I’ve uploaded a CSV file with 700+ rows without issue. Now on, but it was working on too.

How many assets is your asset listing page set to display? (if you’re using one)

(Lewis) #5

Hi @nnhubbard. Yeah, they’re all showing in the asset listing. Seems odd that they don’t all show in the asset map too - it’s a bit jarring. Guess it’s by design?

(Lewis) #6

Hey @Edward. Yes, I think this must be by design - S5 only shows the first 50 in the asset map. Is this your experience?

As I said to @nnhubbard, they’re all coming through in the asset listing.

(Nic Hubbard) #7

Did you try double clicking the “Viewing x of x” option? That will load more shadow assets.


(Lewis) #8

Hi @nnhubbard unfortunately, I don’t get that appear in v5.5.3.3



ah ok, in the backend. No, I see all assets (65).