Squiz SOAP Server Procedure Not Present Error

(Lewis) #1


I’m using a SOAP server I previously created in Squiz v5.5.3.3 and recently I’ve added the File Retrieval Service.

I’ve regenerated the WSDL (ticked the box on the SOAP Server’s Details screen) but each time I run a test on the Custom Form’s Submission Actions screen, I get “Procedure CreateAsset not present”. Incidentally, the new File Retrieval Service procedures aren’t showing in the Action dropdown list on the Submission Action screen either, hence I’m using CreateAsset (a procedure that was already present before) to test and see if the SOAP server is responding at all.

Any ideas? I’ve recached the SOAP server, removed the SOAP API Asset Service altogether and recreated it, refreshed the WSDL in the SOAP server and even tried changing the URL of the SOAP server altogether to force the changes through but I still can’t even access CreateAsset now and the File Retrieval Service procedures still aren’t showing, as I’ve said.