Disable SquizEdge cache for a page

(Harinder Singh) #1

Matrix Version:

I have a disclaimer page where I am storing cookie value if the user agrees with TCs. It used to work without any hiccups. But now because of SquizEdge is in place, we started facing the caching issue. The page is loading from Cache no matter how many times you click on the “Agree” button or refresh browser.

If I do hard refresh by using /_recache only then I am seeing expected content.

Any solution, to avoid cache for these sections or any ESI tags which I can use in my design to skip cache?

(John gill) #2

You’ll need to give it a Root Node Specific rule in Cache Manager and disable “Send cacheable header”

(Harinder Singh) #3

Thanks John. I will give it a go