Git File Bridge using HTTPS

(Rob) #1

Hi all,

I come cap in hand once again as I’m trying to connect a git file bridge asset to a public repository. I would use the SHH method but because our I.T don’t allow SSH open to the public I can’t do that.

I’ve followed the Squiz guide to the letter but when I try and clone the repository I get the following error inside the matrix which I am unable to troubleshoot as I’m unable to access any root user permission levels or run anything on the command line.

The only thing I haven’t tried yet is getting our I.T team to add the repository url to our network listing of allowed URLs but I wouldn’t have thought that would have been the issue.

Any help greatly appreciated as always!



(John gill) #2

Oh dear, it looks like Matrix doesn’t escape passwords when building the git URI so if you have an @ symbol in your password it doesn’t work (and also exposes the part of your password after the @).

I think the @ should be being escaped to %40,

Only solution will be to not use any reserved characters in your github password.

(Rob) #3

John! I was so hoping this was going to be the case so I changed the password to not use special characters and now the error I get is…

Error occurred when running git command "/usr/bin/git ls-remote 'https://Maidstone-Borough-Council-Digital:*****'": error: Failed connect to; Operation now in progress while accessing https://Maidstone-Borough-Council-Digital:*****, , fatal: HTTP request failed

I also tried deleting the initial bridge asset and creating a new one. If its failing the connection to github then I may need to speak to I.T.

Thanks again for the help John!



(John gill) #4

Unlucky, looks like one for IT.

There’s not a huge amount to go on with the “HTTP request failed” but I’d be tempted to create a Remote Content Asset and give it the URL . If that can fetch the github page you know the issue is just with the git side of things, but if it can’t then there’s a good chance you’ve got general HTTP trouble.

(Rob) #5

Just tested the remote content John and its pulling info back absolutely fine. Does this mean the issues is then with the git file bridge I’ve configured?

See screenshot below:

(John gill) #6

or the issue is with git on the server. Maybe there’s a HTTP proxy that Matrix is using to do the Remote Content request, but git isn’t set up to use it?

One for IT I think.

(Rob) #7

That sounds like it could be the issue! I’ll do some digging and report back with how I get on.

Thanks again for all the help!