Global preference not being applied


Matrix Version: 6.30.0

We have the default preferences for our components set to “Raw (no formatting)” but whenever we use the default matrix WYSIWYG component it always creates the presentation tag as “Block (div)”.

Does anybody know how we can force this to be “Raw (no formatting)” so we don’t have to always take the extra steps of changing the presentation tag manually?

Unfortunately, we already have hundreds to change manually as we didn’t realise the Global Preferences weren’t working until some of our site had already moved to new components in Matrix 6.


Update: I changed the default component type to something else and then back again and it seems to have reset the default presentation type when I create a new page so thats a start.

What is still a problem though is that when I then add a new basic WYSIWYG component it still has the wrong formatting. Anyone know how to reset the default WYSIWYG component to always use raw formatting?


UPDATE: Ok, so I was a bit early saying it was half working. We’re now back to every new component using a block div instead of a raw div. Quite annoying to have to change every single time we use a component. Anyone know how to fix?


Any one have an idea about this? Our preferences are fine but Matrix is ignoring our settings. We really want components to stop using Block Divs as the default.

(Kenny Cameron) #5

We just noticed this as well and I raised a support ticket — it’s a known internal bug just now, hopefully being fixed in of the next releases :slight_smile:

If it helps, I found that the setting respects the very first WYSIWYG container added when a new page is created. So you could clone containers for the moment to save a bit of time in changing settings.


Thanks mate, glad to know its not something on our end. Hopefully fixed soon, especially as you’ve raised a ticket.