Updating thumbnail when a metadata field is updated

(Brad Ingram) #1

Matrix Version:

Hey gang, i have an issue where i cant get the Set Thumbnail trigger action to work when a related asset metadata field is updated with an image.

Here is the setup:

Event: Asset Updated
Condition: Asset is of type - Page
Condition: Tree Location - Site Asset

Keyword being used is asset_metadata_header.image, i have tried globals_asset_metadata_header.image but that gives an error saying that it is not a valid asset id.

What am i missing here?

Cheers, Brad.

(Hugh McMaster) #2

You should choose Standard Page for the asset type. A Page asset is a superset of many asset types.

The “Current Asset” source sets the root node for the current asset, so nothing will happen. You want Set Value.

That said, I encountered a server-side parsing error for all keywords I tried. @Bart, is this a known bug?

(Brad Ingram) #3

Gday Hugh,

I made those changes, applied the “Set Value” source and used the keyword %asset_metadata_header.image%.

This throws this error:

[ASSERT EXCEPTION] [string] “%asset_metadata_header.image%” is not a valid asset ID [SYS0320]

Which doesnt make much sense, as when i use this keyword in an asset listing, it brings through the Asset ID? is this one of the parsing errors you encountered?


(Hugh McMaster) #4

Yes. This looks very much like a bug. I tried many keywords that would produce an asset ID, but all attempts ended with this error. @Bart

(Bart Banda) #5

Yeah it does look like a bug, or a missing feature as sometimes that interface has a checkbox that you can enable where you specify “Replace keywords in Set value”, but others don’t and replace the keyword anyway. Will report as a bug.

As a workaround, you can use the create link trigger action as a thumbnail is simply a NOTICE link with a specific link value (“thumbnail”). Annoying thing is that you need to set a hardcoded link target in order to set a dynamic one (which is a known potential bug).


(Hugh McMaster) #6

This is a useful workaround, Bart, thanks for the reply.